Experiencing degraded service on DeepAffex North America (NA-East)

Incident Report for DeepAffex Cloud

Resolved

The Amazon Web Services (AWS) outage has been resolved.
🔗 https://health.aws.amazon.com/health/status

All services are operating normally, and we will continue monitoring to ensure ongoing stability.
Posted Oct 20, 2025 - 20:57 EDT

Update

Our services are operational following the recovery of the Amazon AWS outage. We will continue monitoring to ensure the ongoing stability of our systems.
Posted Oct 20, 2025 - 18:45 EDT

Monitoring

We are continuing to see improved measurement stability while awaiting full recovery from the AWS outage. Our team will continue monitoring the situation closely.
https://health.aws.amazon.com/health/status
Posted Oct 20, 2025 - 17:08 EDT

Update

Amazon Web Services (AWS) continues to see improvements in their environment, but there is still no estimated time of resolution.
🔗 https://health.aws.amazon.com/health/status

We’re monitoring the situation closely and will provide updates as new information becomes available.
Posted Oct 20, 2025 - 16:29 EDT

Update

We are still experiencing degraded service performance due to an ongoing AWS outage.
You can monitor AWS’s official status here: available.https://health.aws.amazon.com/health/status

We continue to monitor the situation closely, and further updates will be provided as more information becomes available.
Posted Oct 20, 2025 - 15:08 EDT

Update

We are still experiencing degraded service due to the ongoing AWS outage.
🔗 https://health.aws.amazon.com/health/status

Our team continues to monitor the situation closely and will share further updates as they become available.
Posted Oct 20, 2025 - 12:53 EDT

Identified

We are currently experiencing degraded service due to an ongoing AWS outage.
🔗 https://health.aws.amazon.com/health/status

We are closely tracking the issue and will provide further updates as more information becomes available.
Posted Oct 20, 2025 - 12:09 EDT
This incident affected: North America (NA-East) cluster.